Re: [boost] [type_traits] Rewrite and dependency free version

On Mon, Feb 2, 2015 at 11:57 AM, Robert Ramey
this is the result of naming issues. the word array has been used for boost::array, std::array and the built-in C/C++ array. They all ended up in the same header so that one could find them when they were needed.
Ideally they should be separated, and boost::array's serialization should go into a boost::array header. As for serialization core dependencies, isn't it possible to define serialization function template overloads for user-defined types without including serialization library headers? E.g. aren't all function calls one makes in operator<< overloads dependent on the archive template argument? -- Emil Dotchevski Reverge Studios, Inc. http://www.revergestudios.com/reblog/index.php?n=ReCode

Emil Dotchevski wrote:
As for serialization core dependencies, isn't it possible to define serialization function template overloads for user-defined types without including serialization library headers?
To (properly?) support XML archives, you need at least boost/serialization/nvp.hpp, and if you want to change the tracking level or the implementation level for the type, you generally include the corresponding headers as well, although this could be done with forward declarations. In addition, if you serialize a base class, you need boost/serialization/base_object.hpp. Not sure if that's all, perhaps there's more.
participants (2)
-
Emil Dotchevski
-
Peter Dimov