Emil Dotchevski wrote:
On Sun, Jan 3, 2016 at 10:11 AM, Adam Wulkiewicz
wrote: - The identifiers should be made more verbose. This is true both for function names as well as identifers containing "q"/"v"/"m" parts. The former should be replaced with full words, e.g. "transp" -> "transpose". The latter should be replaced at least with "qua"/"quat"/"vec"/"mat" respectively, so e.g. "v_traits" -> "vector_traits"/"vec_traits", "col_m" -> "col_mat", etc.
Does this include header file names?
I'd say that it depends if those header files are intended to be included by the users. If the users are encouraged to include them manually then I'd make the name as intuitive as possible. If these are headers containing the internals automatically included by some other higher-level header then it doesn't matter that much. However have in mind that the maintainer won't be the only one who will be working with them as there will be other contributors for sure. And in general it's good to use the same naming scheme in the whole library. Adam
If you look in the boost/qvm directory, you'll see that currently the q, v and m prefix naming convention is followed for file names as well (q and v prefixes by analogy):
m.hpp: any size matrix operations m2.hpp: 2D matrix operations m3.hpp: 3D matrix operations m4.hpp: 4D matrix operations m_access.hpp: matrix element access functions m_traits.hpp: m_traits template definition m_traits_array.hpp: m_traits specialization for C arrays
Also:
qv.hpp: operations between quaternions and vectors vm.hpp: operations between vectors and matrices
map_mm.hpp: matrix-to-matrix view proxies map_mv.hpp: matrix-to-vector view proxies map_vm.hpp: vector-to-matrix view proxies
Thanks, Emil
_______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost