On Sun, Apr 21, 2013 at 6:45 PM, Lars Viklund
On Sunday 21 April 2013 16:00:49 Rene Rivera wrote:
Just a quick message to mention that I've finished all the review related changes to the Predef library. And done some of the future tasks on the library. In particular the addition of endianness definitions and the moving of MinGW as a platform instead of a compiler (and hence the addition of BOOST_PLAT category of macros.
And the one question I have is.. When will the review results of the library be decided on? I ask for two reasons. One, the obvious, is just to know if it's accepted or not. And to know if it's not accepted and hence that I should spend time to recreate a "boost/detail/endian.hpp" header that implements the Predef logic for endian detection.
Note the project move to Github earlier this year (in preparation for
On Mon, Apr 22, 2013 at 01:22:33AM +0400, Andrey Semashev wrote: the
Boost git move). You can find the project at < https://github.com/grafikrobot/boost-predef>, and browse the current documentation at http://tinyurl.com/cqqhhev.
I noticed this in the docs:
BOOST_ARCH_X86_64 Intel IA-64 architecture.
x86_64 (aka amd64 and Intel64), which is a widespread extension to IA32 (x86), is not the same as IA64, which is implemented in Itanium CPUs. Could you, please, separate these two architectures?
Also, FYI there is a new "architecture" x86_32 on Linux, which is not legacy x86 described by your BOOST_ARCH_X86_32 macro. x86_32 is essentially x86_64 with 32 bit pointers and size types. You should probably make this clear in the docs and I'd even rename BOOST_ARCH_X86_32 to BOOST_ARCH_X86_LEGACY or something because of this and introduce BOOST_ARCH_X86_32 with the new meaning. Sorry, I don't have specific macros to detect x86_32 right now but it is supported by gcc.
I thought that the mongrel ABI was properly called "x32" [1][2][3]. Searching for x86_32 just seems to hit a bunch of confused people actually meaning the regular boring 32-bit x86.
While they made an odd naming decision calling it "x32", calling it something else than what it's actually called would be a disservice.
Indeed.. I might consider adding an ARCH_X86_X32. Although more appropriate might be ARCH_X86_64_X32. But I'm somewhat reticent to add an ARCH that is just an "emulation" running on X86_64. -- -- -- Grafik - Don't Assume Anything -- Redshift Software, Inc. - http://redshift-software.com -- rrivera/acm.org - grafik/redshift-software.com -- 102708583/icq - grafikrobot/aim - grafikrobot/yahoo