On Mon, Apr 29, 2013 at 10:41 AM, Vicente J. Botet Escriba < vicente.botet@wanadoo.fr> wrote:
BTW, the choice of the names in the C++1y proposal was a source of conflicts (as always). In my prototype I used
fxp_uint and fxp_int fxp_ufract and fxp_fract (fxp_ufreal and fxp_real)
Now if you put these classes on a specific namespace for each notation the choice of the default can be deferred without a major impact on the plan.
namespace fixed_point { namespace q { }
namespace cxx1y {} // if the default is cxx1y notation (a better name is welcome, e.g. rr for range and resolution) using cxx1y::fxp_uint; using cxx1y::fxp_int; ... }
With this approach the user could be precise enough
fixed_point::q::fxp_fract<8,4>**;
we could also name the namespace for fixed points fxp and use
fxp::q::fract<8,4>; fxp::rr::uinteger<8,4>;
Please, no cryptic abbreviations (and especially one letter names).