I have collected the feedback into individual issues for discussion
and to track the progress of changes:
On Thu, Sep 12, 2019 at 2:38 AM Dominique Devienne via Boost
Interestingly, it to be named fixed_capacity_vector, renamed in revision 2 http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2018/p0843r2.html
Which is a much better name IMHO. Longer, sure, but now it's clear and unambiguous. --DD
https://github.com/vinniefalco/fixed_string/issues/1
On Thu, Sep 12, 2019 at 4:29 AM degski via Boost
...the class should be made constexpr.
https://github.com/vinniefalco/fixed_string/issues/2
On Thu, Sep 12, 2019 at 6:19 AM Mike via Boost
...make the string trivially copyable (simply copy the whole storage, not just the bytes actually containing the string).
https://github.com/vinniefalco/fixed_string/issues/3
On Thu, Sep 12, 2019 at 6:19 AM Mike via Boost
...conditionally enable support for std::string_view in c++17 (implicit conversion to and explicit construction from string_view)
https://github.com/vinniefalco/fixed_string/issues/5
https://github.com/vinniefalco/fixed_string/issues/7
On Thu, Sep 12, 2019 at 7:29 AM Bjorn Reese via Boost
For the string_view to bikeshedding_string conversion I would prefer a temmplated constructor that takes a container (a Range concept to be precise.)
https://github.com/vinniefalco/fixed_string/issues/6
On Tue, Sep 10, 2019 at 6:15 AM Phil Endecott via Boost
...if small size is an aim (and I think it should be), we can do better; when N < 256, use a uint8_t for the size. In fact, use boost::integer::uint_t< log2<N> >::least and get an optimal type for the size.
https://github.com/vinniefalco/fixed_string/issues/8 Feel free to add to these issues or to create new ones (or discuss on the list) Thanks