On Tue, Mar 19, 2013 at 6:00 PM, Rene Rivera
On Tue, Mar 19, 2013 at 3:59 AM, Marc Glisse
wrote: BOOST_BIG_ENDIAN or BOOST_LITTLE_ENDIAN, BOOST_BYTE_ORDER which can be 4321 or 1234, etc.
If you read the documentation for the Predef library you would see that I'm following a particular naming convention that defines categories (BOOST_category_subcat_subsubcat). I do have some questions regarding the BYTE_ORDER macros..
Are the macros defining the 4321/1234 numbers actually needed? Are there situations where the on/off indicator macros aren't enough?
According to Wikipedia [1], there are cases of mixed endianness, so the BOOST_BYTE_ORDER macro could have e.g. value 3412. Also, FP endianness may differ from the one of integers, so probably there have to be separate sets of macros for these. [1] http://en.wikipedia.org/wiki/Endianness