20 Sep
2013
20 Sep
'13
10:52 a.m.
"I think a new syntax should be used to minimize confusion between the two concepts" IMHO the pipe syntax should just be a shorthand for (left associative) function application, i.e.: x | f should simply be a equivalent to f(x)
Actually what I really want is a global pipe operator which works like that, I just aimed for boost::range::algorithms because range::adaptors already utilized the syntax.
I suppose we could have a utility library that defines a macro to generate the wrapper You mean a macro like: "MAKE_PIPEABLE(boost::accumulate, accumulated);"?
Regard /Viktor