I'm not sure what the "N" in "FN" is, so I don't see that as a good choice.
A lot of times people abbreviate function as fn.
Names like Boost.FP or Boost.FPL could imply that it provides full functional constructs whereas Boost.Fit does not and is mainly focused on functions.
I agree that those are not good.
Boost.Fun would be a fun name and arguably fits (pun intended).
True.
Boost.Futil :-)
The name doesn't actually need to be short, so Boost.Function Utilities would be fine. The corresponding namespace name would be long, too, but namespace aliases, using directives, and using declarations can mitigate that.
However, there is not an easy way alias the macros. So `BOOST_FIT_STATIC_LAMBDA_FUNCTION` would become `BOOST_FUNCTION_UTILITIES_STATIC_LAMBDA_FUNCTION`, which is getting too long. I could support ZLang[1] to allow the user to namespace macros, however, I don't think that is widely used. Alternatively, I wonder if its possible to use FunctionUtilities as the library name, but use 'fu' as the namespace name. Paul [1]: https://github.com/pfultz2/ZLang