On 3/21/2015 12:11 PM, Louis Dionne wrote:
Edward Diener
writes: On 3/21/2015 10:20 AM, Louis Dionne wrote:
[...]
Anyway, so the conclusion is that lazy right folds won't be supported in Hana, at least not for a while. So this opens the door for renaming foldl/foldr to fold/reverse_fold. I'll probably start by adding aliases and then consider removing foldl/foldr, because renaming them all at once would require more work, especially with the new naming scheme with no-state overloads that was discussed in the poll at [3]. I hope this sounds reasonable.
I would like to urge you to use easily understandable names in your library rather than shortened and more cryptic names. Any extra typing a user of your library may have to do is easily offset by the fact that more easily understandable names make your library much more understandable to use.
Of course, my goal was never to use more cryptic names for the sole purpose of reducing the number of letters. When it makes sense to do so, I use the names that are used in C++. When there are good reasons not to, I use the names used everywhere else in functional programming.
If you have specific examples of places where I use names that seem cryptic, please point them out. I will be happy to discuss the reasons behind those names and to change them if those reasons are deemed insufficient after consideration.
A name like 'foldl' and 'foldr' is what I mean.