Hi all, Thank you all for participating in the review so far. I'd like to outline some of the changes that have been implemented thus far, and others that are pending as there is not a clear consensus. The live branch can be found at https://github.com/18/fixed_string/tree/review-patch - Empty class specialization for N = 0: Implemented - Use of smallest possible type to store size: Implemented - More noexcept: Mostly implemented, still need to address exception specification for template overloads intended for `string_view` - Hash support: Implemented for both std::hash and boost::hash - Change `substr` to return a `fixed_string` and add a `subview` function: Implemented - Fixed the user configuration macro and changed the name to BOOST_FIXED_STRING_STANDALONE - Added mandatory meta folder A few things on the list of change remain: - `constexpr` all the things!... Only C++20 allows for members to remain uninitialized by a constexpr constructor, so use in previous revisions of the standard would require initialization of each element, which could impose an unacceptable performance penalty - We still have not settled on a name that is concise and descriptive - No consensus has been reached on how operator+ should be implemented - Documentation needs to be updated Thank you, Krystian Stasiowski On Tue, Dec 3, 2019 at 3:11 PM Joaquin M López Muñoz via Boost < boost@lists.boost.org> wrote:
The review period for candidate Boost.FixedString finishes tomorrow, Dec 4.
There's an ongoing lively discussion on many aspects of the library, which is very good, but only three of you have cast your acceptance/rejection vote, which is not good.
This is a gentle petition to the people engaging in the review who haven't voted yet:
Vinícius, Nevin, Mike, Andrzej, JeanHeyd, Hans, Peter, Julien, Andrey, Tim, Gavin, Emil,
(and anyone who might be still lurking) to please submit a review with an explicit vote. If you feel like you need some more time to do the work, I think we are in a position to extend the review period, but please express your intentions before I ask the review wizards.
Thank you!
Joaquín M López Muñoz Review manager for candidate Boost.FixedString
_______________________________________________ Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost