RE: [Boost-users] Re: interest in a glob_iterator? (directory_ite rator with regex)
Jeff Flinn wrote:
And a more descriptive, less jargon-ish name.
Why? Rich is proposing something that would iterate over the files returned by the unix 'glob' function. As much as you might hate to admit it, you must recognize that the world does not revolve around UNIX (and before anyone claims otherwise, nor does
Angus Leeming [mailto:angus.leeming@btopenworld.com] wrote: the world revolve around Windows). To my knowledge, "glob" is not a standard computer term, nor a standard C++ term, it is a standard UNIX term. Now, I could be wrong, but my understanding of the ISO standardization process is make everything platform-independent (and keep in mind that one of the original goals of Boost was to be included in the Standard). The *concept* of the "glob" is pretty much platform independent, but the term is not, so it should have (to paraphrase Jeff) a more descriptive, less platform-specific name. -- Jim Hyslop Senior Software Designer Leitch Technology International Inc. (http://www.leitch.com/) Columnist, C/C++ Users Journal (http://www.cuj.com/experts)
Seems that "glob" is pretty common, if not standard, to me. Examples: ======== Python - http://www.python.org/doc/current/lib/module-glob.html Perl - Camel book Ruby - http://www.rubycentral.com/book/ref_c_dir.html#Dir.glob PHP - http://us4.php.net/manual/en/function.glob.php M$'s Site Server - http://msdn.microsoft.com/library/default.asp?url=/library/en-us/siteserv/ht... M$'s SMTP Server - http://msdn.microsoft.com/library/default.asp?url=/library/en-us/smtpevt/htm... M$'s UNIX Application Migration Guide - http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnucmg/html... Standard C++ cannot do globbing, without help, so of course it doesn't define it. -d Jim.Hyslop wrote:
Angus Leeming [mailto:angus.leeming@btopenworld.com] wrote:
Jeff Flinn wrote:
And a more descriptive, less jargon-ish name.
Why? Rich is proposing something that would iterate over the files returned by the unix 'glob' function.
As much as you might hate to admit it, you must recognize that the world does not revolve around UNIX (and before anyone claims otherwise, nor does the world revolve around Windows).
To my knowledge, "glob" is not a standard computer term, nor a standard C++ term, it is a standard UNIX term. Now, I could be wrong, but my understanding of the ISO standardization process is make everything platform-independent (and keep in mind that one of the original goals of Boost was to be included in the Standard). The *concept* of the "glob" is pretty much platform independent, but the term is not, so it should have (to paraphrase Jeff) a more descriptive, less platform-specific name.
-- David Ohlemacher BBN Technologies 127 John Clarke Rd. Middletown, RI 02878 Phone: (401)848-3542, Fax:(401)849-8611 ohlemacher at bbn dot com
On Thursday, January 15, 2004, at 09:40 AM, Jim.Hyslop wrote:
Jeff Flinn wrote:
And a more descriptive, less jargon-ish name.
Why? Rich is proposing something that would iterate over the files returned by the unix 'glob' function. As much as you might hate to admit it, you must recognize that the world does not revolve around UNIX (and before anyone claims otherwise, nor does
Angus Leeming [mailto:angus.leeming@btopenworld.com] wrote: the world revolve around Windows). Of course not....it revolves around the Mac :-) (whoops, better duck and cover)
To my knowledge, "glob" is not a standard computer term, nor a standard C++ term, it is a standard UNIX term. Now, I could be wrong, but my understanding of the ISO standardization process is make everything platform-independent (and keep in mind that one of the original goals of Boost was to be included in the Standard). The *concept* of the "glob" is pretty much platform independent, but the term is not, so it should have (to paraphrase Jeff) a more descriptive, less platform-specific name.
Oh, I'll confess that I thought "glob()" was already part of the POSIX standard; but I'll admit I didn't look to be sure. Anyway, the point is taken. To rephrase Russell's comment: " I don't care what it's called as long as I have its function!" Would a better name be "wildcard_iterator"? filtered_directory_iterator? perhaps "filename_iterator"? Can anyone offer other suggestions? And while we're on the subject of platform/environment independence: What should be the set of meta-characters? The initial implementation supports csh/bash style "*", "?", "[ab-z]", "[^ab-z]", and "{a,b}". Should the set be expanded? restricted? --rich
participants (3)
-
David Ohlemacher
-
Jim.Hyslop
-
Rich Johnson