
15 Sep
2006
15 Sep
'06
4:36 p.m.
How can make the following code inside of for_each more readable? void f(char*); typedef std::map<int,char> TMap; TMap a; std::for_each(a.begin(),a.end(),boost::bind(f,boost::bind(&TMap::value_type::second,_1))); Is it possible to convert boost::bind(&TMap::value_type::second,_1) to a function object or a typedef name? -- Regards, Alexander. http://sjcomp.com