9 Jul
2007
9 Jul
'07
7:35 p.m.
Wouldn't it be better if boost::lambda::bind was named boost::lambda::call (or boost::lambda::eval, to make it more lispish), in order to: -avoid the confusion and potential overlap with boost::bind -make the name more sensible within lambda expressions, especially when "binding" nullary functions, ie. int six() { return 6; } if_(call(six) == 6) [ ... ] IMHO looks better than if_(bind(six) == 6) [ ... ] Yours, Chuj