Deane Yang
I'm sorry if I'm being dumb about this, but I've run into the following difficulty a couple of times with boost libraries.
I've decided to try using the new boost iterator library. Based on the documentation, I think I want to use iterator_adaptor.
But scanning through the documentation, I don't immediately see - what namespace iterator_adaptor lives in. I assume it's just boost,
Right. Everything lives in boost:: unless otherwise specified.
but it probably doesn't hurt to mention this explicitly, since some boost libraries use sub-namespaces.
OK, where should it be mentioned?
- what header file to include. I couldn't find this in the documentation.
Thanks, that's a known problem. Thomas, when you do the editing you
have planned, can you correct it? I'm guessing that sections like
"indirect_iterator synopsis" should be renamed, e.g.,
"
I can figure all of this out, but it is helpful to have it specified in the documentation.
Agreed. -- Dave Abrahams Boost Consulting www.boost-consulting.com