On Sat, Mar 29, 2008 at 7:06 PM, Steven Watanabe <watanabesj@gmail.com> wrote:
AMDG
I was just thinking of moving the duplicated code into CRTPPacket
Robert Dailey wrote:
>
>
> struct WalkPacket : CRTPPacket<WalkPacket, PID_WALKPACKET> {}; ?
>
>
> What exactly is this structure supposed to present?
template<class Derived, PacketID Id>
struct CRTPPacket : Packet {
static const PacketID ID = Id;
virtual PacketID getID() const { return(ID); }
};
In Christ,
Steven Watanabe