
19 Jul
2007
19 Jul
'07
3:51 p.m.
The docs explain that a parameter can be named: typedef parameter::parameters< required<tag::threading_policy> ...
class_signature; ... class_<threading_policy<single_threaded>,...>;
or else be deduced: typedef parameter::parameters< required< deduced<tag::threading_policy>, is_base_and_derived<threading_policy_marker,_> > ...
class_signature; ... class multithreaded: threading_policy_marker{...}; class_<multithreaded,...>;
Now, is it possible to combine these two options into one, so that the the two syntaxes class_<threading_policy<single_threaded>,...>; class_<multithreaded,...>; are accepted? If so, how? Thank you, Joaquín M López Muñoz Telefónica, Investigación y Desarrollo