
Hi Gennadiy, thank you for getting back to me.
On 2 September 2012 04:08, Gennadiy Rozental
Aras Vaichas
writes: Hello,
I've just started using the Boost Unit Test Framework so my problem may be a bit naive.
I would like to name each test suite after each of my classes.
e.g.
class foo { }
BOOST_AUTO_TEST_SUITE(foo)
Why don't you use test suite name foo_test(s)?
Because it seemed redundant. My application contains unit tests grouped by unit test suites. Therefore everything in it is already a test, so each suite is named after the class that it tests. I should be able to name it whatever I choose. From a user's point of view, it's just a name for a test suite, there shouldn't be side effects to choosing a name.
Naming test suites the same as the component under test is not a good practice IMO.
Perhaps not, but the API shouldn't dictate policy. Do you agree? It's a simple fix, do you want me to forward a patch? Aras